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MICROSOFT EXCEL  
MS-Excel is the most popular spreadsheet program available under the Windows environment.
A spreadsheet is a grid of rows and columns. It has powerful calculations and graphic capabilities. 
The worksheet comprises of 65534 rows and 256 columns. The columns are numbered as A,B,C…….Z, AA, AB….AZ,BA,BB………….. IV and the rows follow the normal decimal system  1,2,3………65534. The intersection of ROW and COLUMN make a cell referred by its cell address. e.g.:

	A1
	The first cell in column A.

	A2
	The second cell in column A.

	B100
	The 100th cell in column B.


A cell can hold the following  type of data e.g.: Number, Text Date and formula. Perform calculations by formula.

A formula should begin with 'equal to' sign (=) and may contain numbers and cell references. E.g.. : 
=A10+1234

 =B3*7.

Mathematical Operators.

	Description
	Operator
	Examples

	Add
	+
	=A1+C4+30

	Subtract
	-
	=A5-B5

	Divide
	/
	=B5/6

	Multiply
	*
	=B8*C7

	Exponent
	^
	=A3^2


Create a new workbook

1. On the File menu, click New.

2. To create a new, blank workbook, click the General tab, and then double-click the Workbook icon.

To create a workbook based on a template, click the Spreadsheet Solutions tab or the tab listing your custom templates, and then double-click the template for the type of workbook you want to create.

Note   If you don't see the template you want in the New dialog box, make sure the template is installed and located in the correct folder.
Open a workbook

In Microsoft Excel, you can open workbooks that are stored on your hard disk or on network drives that you have connections to. You also can open workbooks on your network without first setting up a connection to a network server if your network supports UNC addresses. If you want to make sure that a workbook remains unchanged, and you have permission to save files where the workbook is stored, you can create and work on a copy of the workbook instead of the original file, or you can open the workbook as read-only, regardless of its location.

You can also open workbooks on your Intranet, if your company has this kind of internal Web. You can open workbooks at HTTP sites on the World Wide Web and FTP sites on the Internet. For access to Internet and World Wide Web sites, you need access to the Internet either through a direct network connection or through a dial-in Internet service provider.

MANAGING FILES
Copy / Delete a file
1. Click Open from File Menu .

2. In the Look in box, click the drive or folder that contains the file you want to copy.

3. In the folder list, double-click folders until you open the folder that contains the file you want.

4. Right-click the file you want to Copy/delete, and then click Delete on the shortcut menu.
Move a file

1. Click File->Open.
2. In the Look in box, click the drive or folder that contains the file you want to move.

3. In the folder list, double-click folders until you open the folder that contains the file you want.

4. Right-click the file you want to move, and then click Cut on the shortcut menu.

5. In the Look in box, click the drive or folder you want to move the file to.

6. In the folder list, double-click folders until you open the folder you want to move the file to.

7. Right-click in the folder list (make sure a file is not selected), and then click Paste on the shortcut menu.

The Paste command is not available if a file is selected in the folder list.
Rename a file

1. Click Open  .

2. In the Look in box, click the drive or folder that contains the file you want to rename.

3. In the folder list, double-click folders until you open the folder that contains the file you want.

4. Right-click the file you want to rename, and then click Rename on the shortcut menu.

5. Type the new name, and then press ENTER.
Working with workbooks and worksheets

About workbooks and worksheets

In Microsoft Excel, a workbook is the file, in which you work and store your data. Because each workbook can contain many sheets, you can organize various kinds of related information in a single file.

Use worksheets to list and analyze data. You can enter and edit data on several worksheets simultaneously and perform calculations based on data from multiple worksheets. When you create a chart, you can place the chart on the worksheet with its related data or on a separate chart sheet.

The names of the sheets appear on tabs at the bottom of the workbook window. To move from sheet to sheet, click the sheet tabs. The name of the active sheet is bold.

Note   If you open a workbook created in earlier versions of Microsoft Excel, Microsoft Excel 97 preserves macro sheets and dialog sheets and converts module sheets into modules in the workbook's Visual Basic project. You can run and modify your Microsoft Excel version 4.0 macros and Microsoft Excel version 5.0 and 7.0 dialog sheets in Microsoft Excel 97, and you can add new macro sheets and dialog sheets by right-clicking a sheet tab and then clicking Insert on the shortcut menu. However, it's recommended that you create new macros and dialog boxes in the Visual Basic Editor. To view and modify converted Visual Basic module sheets or to create new macros and dialog boxes, point to Macro on the Tools menu, and then click Visual Basic Editor.

Function keys in Microsoft Excel

MS-Excel provides you an easy way of performing normal tasks. A few of the important function keys and other shortcuts are listed below.
	Function Key
	Function

	F1
	Display Help

	F2
	Edit the active cel

	F3
	Paste a name into a formula

	F4
	Repeat the last action,Repeat the last Find (Find Next)


	F5
	Go To 

	F6
	Move to the next pane

	F7
	Spelling command

	F8
	Extend a selection

	F9
	Calculate all sheets in all open workbooks

	F10
	Make the menu bar active

	F11
	Create a chart

	F12
	Save As command


Enter data by using shortcut keys

	To do this
	Press

	Complete a cell entry
	ENTER

	Cancel a cell entry
	ESC

	Repeat the last action
	F4 or CTRL+Y

	Start a new line in the same cell
	ALT+ENTER

	Delete the character to the left of the insertion point, or delete the selection
	BACKSPACE

	Delete the character to the right of the insertion point, or delete the selection
	DELETE

	Delete text to the end of the line
	CTRL+DELETE

	Move one character up, down, left, or right
	Arrow keys

	Move to the beginning of the line
	HOME

	Edit a cell comment
	SHIFT+F2

	Fill down
	CTRL+D

	Fill to the right
	CTRL+R

	Fill the selected cell range with the current entry
	CTRL+ENTER

	Complete a cell entry and move down in the selection
	ENTER

	Complete a cell entry and move up in the selection
	SHIFT+ENTER

	Complete a cell entry and move to the right in the selection
	TAB

	Complete a cell entry and move to the left in the selection
	SHIFT+TAB


Work in cells or the formula bar by using shortcut keys

	To do this
	Press

	Start a formula
	= (EQUAL SIGN)

	Cancel an entry in the cell or formula bar
	ESC

	Edit the active cell
	F2

	Insert the AutoSum formula

SIGN)
	ALT+= (EQUAL 



	Enter the date

(SEMICOLON)
	CTRL+; 



	Enter the time

(COLON)
	CTRL+SHIFT+: 



	Display the Formula Palette after you type a valid function name in a formula
	CTRL+A


Manage  numbers, text, a date, or a time

1. Click the cell where you want to enter data.

2. Type the data and press ENTER or TAB.

Use a slash or a hyphen to separate the parts of a date; for example, type 9/5/96 or Jun-96.

To enter a time based on the 12-hour clock, type a space and then a or p after the time; for example, 9:00 p. Otherwise, Microsoft Excel enters the time as AM.

Tip

·
To enter today's date, press CTRL+; (semicolon).

·
To enter the current time, press CTRL+SHIFT+: (colon).

Move and scroll through a worksheet

To move between cells on a worksheet, click any cell or use the arrow keys. When you move to a cell, it becomes the active cell. To see a different area of the sheet, use the scroll bars.
	To scroll
	Do this

	One row up or down
	Click the arrows in the vertical scroll bar.

	One column left or right
	Click the arrows in the horizontal scroll bar.

	One window up or down
	Click above or below the scroll box in the vertical scroll bar.

	One window left or right bar.
	Click to the left or right of the scroll box in the horizontal scroll 

	A large distance

	Drag the scroll box to the approximate relative position. In a very large worksheet, hold down SHIFT while dragging.


Tip   The size of a scroll box indicates the proportional amount of the used area of the sheet that is visible in the window. The position of a scroll box indicates the relative location of the visible area within the worksheet.

Select cells on a worksheet

Before you can carry out most commands or tasks in Microsoft Excel, you must select the cells you want to work with.

To Select one or more cells, entire rows and columns, or all cells on a sheet
	SELECTIONS
	METHOD

	A single cell 
	Click the cell, or press the arrow keys to move to the cell

	A range of cells to the last cell
	Click the first cell of the range, and then drag

	All cells on a worksheet
	Click the Select All button.

	Nonadjacent cells or cell ranges
	Select the first cell or range of cells, and then hold down CTRL and select the other cells or ranges.

	A large range of cells
	Click the first cell in the range, and then hold down SHIFT and click the last cell in the range. You can scroll to make the last cell visible.

	An entire row
	Click the row heading.

	An entire column
	Click the column heading.

	Adjacent rows or columns
	Drag across the row or column headings. Or select the first row or column; then hold down SHIFT and select the last row or column.

	Nonadjacent rows or columns
	Select the first row or column, and then hold down CTRL 

and select the other rows or columns.

	More or fewer cells than the active selection
	Hold down SHIFT and click the last cell you want to include in the new selection. The rectangular range between the active cell and the cell you click becomes the new selection


Switch to another sheet in a workbook

Click the sheet tab for the other sheet.

If you don't see the tab you want, click the tab scrolling buttons to display the tab. Then click the tab.

Tip   If your workbook contains many sheets, right-click the tab scrolling buttons. Then click the sheet you want.

Edit cell contents

1. Double-click the cell that contains the data you want to edit.

2. Make any changes to the cell contents.

3. To enter your changes, press ENTER.

To cancel your changes, press ESC.

Clear or delete cells, rows, or columns

When you delete cells, Microsoft Excel removes them from the worksheet and shifts the surrounding cells to fill the space. When you clear cells, you remove the cell contents (formulas and data), formats, or comments, but leave the blank cells on the worksheet.

To Clear contents, formats, or comments from cells

1. Select the cells, rows, or columns you want to clear.

2. On the Edit menu, point to Clear, and then click All, Contents, Formats, or Comments.

To Delete cells, rows, or columns

1. Select the cells, rows, or columns you want to delete.

2. On the Edit menu, click Delete.

Surrounding cells shift to fill the space.

Find or replace data

You can search for specific text or numbers you want to review or edit, and automatically replace the found data. You can find all cells that contain the same kind of data, such as formulas, and cells whose contents do not match the active cell.

To find data in a list, you can use filters to display only the rows that contain the desired data. For example, in a list that includes international sales data, you can display just domestic sales.

To Find text or numbers

1. Select the range of cells you want to search.

To search the entire sheet, click any cell.

1. On the Edit menu, click Find.

2. In the Find what box, enter the text or numbers you want to search for.

3. In the Look in box, click the type of information you want to search for.

4. Click Find Next.

Note   To cancel a search in progress, press ESC.

Find and replace text or numbers

1. Select the range of cells you want to search.

To search the entire sheet, click any cell.

1. On the Edit menu, click Replace.

2. In the Find what box, enter the text or numbers you want to search for.

3. In the Replace with box, enter the replacement characters.

To delete the characters in the Find what box, leave the Replace with box blank.

1. Click Find Next.

2. To replace the highlighted occurrence of the found characters, click Replace.

To replace all occurrences of the found characters, click Replace All.

Wildcard characters you can use to find text or numbers

To find text or numbers that have some characters or digits in common, use a wildcard character. A wildcard character represents one or more unspecified characters.

To find 



Use


Example

Any single character in the same

 position as the question mark

? (question mark)
sm?th

Any number of characters in 

the same position as the asterisk
* (asterisk)

*east finds "Northeast" and 

"Southeast"

Move or copy cell data

When you copy a cell by dragging or by clicking Cut    or Copy  , and Paste  , Microsoft Excel copies the entire cell, including formulas and their resulting values, comments, and cell formats.

If the selected copy area includes hidden cells, Microsoft Excel also copies the hidden cells. If the paste area contains hidden rows or columns, you might need to unhide the paste area to see all of the copied cells.

Copy only values, formulas, comments, or cell formats

Instead of copying entire cells, you can copy specified contents from the cells  for example, you can copy the resulting value of a formula without copying the formula itself.

1
Select the cells you want to copy.

2
Click Copy  .

3
Select the upper-left cell of the paste area.

4
On the Edit menu, click Paste Special.

5
Click an option under Paste, and then click OK.

Switch rows of cells to columns or columns to rows

Data from the top row of the copy area appears in the left column of the paste area, and data from the left column appears in the top row.

1
Select the cells that you want to switch.

2
Click Copy  .

3
Select the upper-left cell of the paste area. The paste area must be outside the copy area.

4
On the Edit menu, click Paste Special.

Select the Transpose check box.

Insert cells, rows, or columns

You can insert blank cells, rows, and columns and fill them with data. If you're moving and copying cells, you can insert them between the existing cells to avoid pasting over data.

Insert blank cells

1
Select a range of existing cells where you want to insert the new blank cells. Select the same number of cells as you want to insert.

2
On the Insert menu, click Cells. Click Shift cells right or Shift cells down.

Insert rows/ columns

1
To insert a single row, click a cell in the row immediately below where you want the new row. For example, to insert a new row above Row 5, click a cell in Row 5.

2
To insert multiple rows, select rows immediately below where you want the new rows. Select the same number of rows as you want to insert.

3
On the Insert menu, click Rows. 


Insert moved or copied cells between existing cells

4
To insert columns click columns.

Check spelling or automatically correct spelling errors

You can check spelling on all types of sheets. If you use words that aren't in the main dictionary - such as acronyms or proper names  you can add the words to a custom dictionary. Microsoft Excel will then question the words only if they're misspelled.

The AutoCorrect feature in Microsoft Excel can correct many common typing errors as you work; for example, it can change "adn" to "and" and change "their is" to "there is." You can add new AutoCorrect entries to correct additional words you often mistype.

Microsoft Excel shares spelling dictionaries and AutoCorrect entries with other Microsoft Office applications you might use.

To Check spelling

1
Select the range of cells you want to check. 

2
To check the entire sheet, click any cell.

3
Click Spelling  .

Correct spelling and typing errors as you type

1
On the Tools menu, click AutoCorrect.

2
Make sure the Replace text as you type check box is selected.

3
In the Replace box, type the word that you often mistype or misspell ¾ for example, usually in the With box, type the correct spelling of the word - for example, type usually

4
Click Add.

To Add words to a custom spelling dictionary

1
Click Spelling  .

2
When a word that you want to add to a custom dictionary is identified, click the custom dictionary in the Add words to box. Click Add. 

To Add an AutoCorrect entry during a spelling check

1
Click Spelling  .

2
When a word that you often misspell or mistype is identified, type the correct spelling in the Change to box. If you aren't sure of the spelling, click Suggest, and then click the correct spelling in the Suggestions list.

3
To add the misspelled word to the list of automatic corrections, click AutoCorrect.

Formatting your worksheet

Change the size, font, color, or other text format

You can specify a font, font size, and font color by clicking buttons on the Formatting toolbar. If a small amount of data is not visible in a cell, you can shrink the text to fit the cell; if you later adjust the column width, Microsoft Excel adjusts the size of the text automatically. By using options on the Font tab (Cells command, Format menu), you can also cross out, or "strike through," selected text, or you can format text as superscript or subscript characters.

To Change the font or font size

1
Select whole cells or the specific text in a single cell that you want to format.

2
In the Font box  , click the font you want.

To Shrink the font size to show all data in a cell

If a small amount of data isn't visible in a cell, you can reduce the font size of the data so that you don't have to resize the column.

To show multiple lines of text in a cell, use the Wrap text check box on the Alignment tab.

1
Select the cells you want to format.

2
On the Format menu, click Cells, and then click the Alignment tab.

3
Select the Shrink to fit check box.

To Change the default font and font size used in new workbooks

1
On the Tools menu, click Options, and then click the General tab.

2
In the Standard font box, click a font.

3
In the Size box, enter a font size.

Note   You must restart Microsoft Excel to begin using the new default font and font size. The new default font and font size are used only in the new workbooks you create after you restart Microsoft Excel; existing workbooks are not affected.

Applying Borders, Shading, Background Patterns

Apply borders to cells

1
Select the cells you want to add borders to.

2
To apply the most recently selected border style, click Borders  .

3
To apply a different border style, click the arrow next to Borders  , and then click a border on the palette.

Shade cells with solid colors

1
Select the cells you want to apply shading to.

2
To apply the most recently selected color, click Fill Color  .

3
To apply a different color, click the arrow next to Fill Color  ,  and then click a color on the palette.

Shade cells with patterns

1
Select the cells you want to apply shading to.

2
On the Format menu, click Cells,  and then click the Patterns tab.

3
To include a background color with the pattern, click a color in the Cell shading box.

4
Click the arrow next to the Pattern box, and then click the pattern style and color you want.

5
If you do not select a pattern color, the pattern is black.

Remove borders

1
Select the cells you want to remove borders from.

2
Click the arrow next to Borders  ,  and then click   on the palette.

Remove shading

1
Select the cells you want to remove shading from.

2
Click the arrow next to Fill Color  ,  and then click No Fill.

Printing your Worksheet

To Print the active sheets, a selected range, or an entire workbook

If the worksheet has a defined print area, Microsoft Excel will print only the print area. If you select a range of cells to print and then click Selection, Microsoft Excel prints the selection and ignores any print area defined for the worksheet.

1
On the File menu, click Print.

2
Under Print what, select the option you want.

Tip   If you want to print more than one sheet at the same time, select the sheets before you print. 

To Print cell gridlines

1
Click the worksheet.

2
On the File menu, click Page Setup, and then click the Sheet tab.

3
Click Gridlines.

To Print comments

1
Click the worksheet.

2
On the File menu, click Page Setup, and then click the Sheet tab.

3
To print the comments at the end of the sheet, click At end of sheet in the Comments box.

4
To print the comments where they are displayed on the worksheet, click As displayed on sheet in the Comments box.

To Print a specific area of a worksheet

1
On the View menu, click Page Break Preview.

2
Select the area you want to print.

3
Right-click a cell within the selection, and then click Set Print Area on the shortcut menu.

To Set page margins

1
To set page margins for one sheet, click the worksheet.

2
To set page margins for more than one sheet, select the sheets.

3
On the File menu, click Page Setup, and then click the Margins tab.

4
In the Top, Bottom, Left, and Right boxes, enter the margin size you want.

5
These settings should be larger than the minimum margins required by your printer.

Tip   To see how the page margins will affect the printed document, click Print Preview

Change the worksheet area that appears on a printed page.
If your work doesn't fit exactly on the number of printed pages you want, you can adjust, or scale, your printed work to fit on more or fewer pages than it would at normal size. You can also specify that you want to print your work on a certain number of pages.

To Reduce or enlarge a worksheet to fit the page

1
Click the worksheet.

2
On the File menu, click Page Setup, and then click the Page tab.

3
In the Adjust to box, enter the percentage by which you want to reduce or enlarge the worksheet.

Create custom headers and footers

You can have only one custom header and one custom  footer on each worksheet. If you create a new custom header or footer, it will replace any existing custom header or footer on the worksheet.

1
Click the worksheet.

2
On the View menu, click Header and Footer.

3
To base a custom header or footer on an existing built-in header or footer, click the header or footer in the Header box or Footer box.

4
Click Custom Header or Custom Footer.

5
Click in the Left section, Center section, or Right section box, and then click the buttons to insert the header or footer information, such as the page number, that you want in that section.

6
To enter additional text for the header or footer, enter the text in the Left section, Center section, or Right section box.

7
To start a new line in one of the section boxes, press ENTER.

8
To delete a section of a header or footer, select the section that you want to delete in the section box, and then press BACKSPACE.

Creating a form

You can create your own forms by setting up a worksheet with the text, graphics, and formatting you want and then saving the workbook as a template. To fill out a blank copy of the form, users base a new form on the template by using the New command on the File menu.

Users can print the sheet and fill out the form on paper or fill out the blank cells online and then print the form.

To Create an online or printed form

Before you create a form, decide whether you want users to fill out the form online or on a printed copy.
1
Click New  
2
Add the questions, labels, formulas, and other information you want to appear in the form.

3
Format the worksheet cells to look the way you want.

4
To add check boxes, option buttons, and other controls on a form you will use in Microsoft Excel, you can use controls from the Forms toolbar.

5
If users will fill out the form online, you can specify the information that is valid for each entry.

6
To prevent unwanted changes to an online form, you can allow users to change or enter data only in the cells you specify.

7
Delete any unused sheets from the workbook.

8
When you complete the form, click Save As on the File menu.

9
In the Save as type box, click Template (*.xlt).

10
In the Save in box, select the folder where you want to store the template.

11
In the File name box, type a name for the template, and then save it in the Templates folder or a subfolder.

Fill out an online form

When you fill out a form online, you create a new, blank copy of the form based on the form template. If a template for your form is not displayed on one of the tabs in the New dialog box, ask your system administrator how to find and use the form.

1
On the File menu, click New.

2
Click the tab that contains the template for the form, and then double-click the template.

3
Enter the requested information, and follow any other instructions in the form.

4
Click Save  .

5
In the Look in box, open the folder where you want to store your copy of the form.

6
In the File name box, type a name for the form.

Creating formulas and Auditing the Workbooks

How formulas calculate values

A formula is an equation that analyzes data on a worksheet. Formulas perform operations such as addition, multiplication, and comparison on worksheet values; they can also combine values. Formulas can refer to other cells on the same worksheet, cells on other sheets in the same workbook, or cells on sheets in other workbooks. The following example adds the value of cell B4 and 25 and then divides the result by the sum of cells D5, E5, and F5. For examples of frequently used formulas in Microsoft Excel, click  .

About formula syntax

Formulas calculate values in a specific order that is known as the syntax. The syntax of the formula describes the process of the calculation. A formula in Microsoft Excel begins with an equal sign (=), followed by what the formula calculates. For example, the following formula subtracts 1 from 5. The result of the formula is then displayed in the cell.

=5-1

Usage of Parenthesis

We can use the Parenthesis ( ) to  perform long calculations. The operation inside the parenthesis will be performed first.

E.g.. 
A1+A2   can be performed in MS-Excel by rewriting it as =(A1+A2)/(B3+B10)


B3+B10

About cell references

A formula can refer to a cell. If you want one cell to contain the same value as another cell, enter an equal sign followed by the reference to the cell. The cell that contains the formula is known as a dependent cell ¾ its value depends upon the value in another cell. Whenever the cell that the formula refers to changes, the cell that contains the formula also changes. The following formula multiplies the value in cell B15 by 5. The formula will recalculate whenever the value in cell B15 changes.

=B15*5

Formulas can refer to cells or ranges of cells, or to names or labels that represent cells or ranges. 

About cell and range references

A reference identifies a cell or a range of cells on a worksheet and tells Microsoft Excel where to look for the values or data you want to use in a formula. With references, you can use data contained in different parts of a worksheet in one formula or use the value from one cell in several formulas. You can also refer to cells on other sheets in the same workbook, to other workbooks, and to data in other programs. References to cells in other workbooks are called external references. References to data in other programs are called remote references.

By default, Microsoft Excel uses the A1 reference style, which labels columns with letters (A through IV, for a total of 256 columns) and labels rows with numbers (1 through 65536). To refer to a cell, enter the column letter followed by the row number. For example, D50 refers to the cell at the intersection of column D and row 50. To refer to a range of cells, enter the reference for the cell in the upper-left corner of the range, a colon (:), and then the reference to the cell in the lower-right corner of the range. The following are examples of references.

To refer to






Use

The cell in column A and row 10
A10

The range of cells in column A and rows 10 through 20

A10:A20

The range of cells in row 15 and columns B through E

B15:E15

All cells in row 5






5:5

All cells in rows 5 through 10




5:10

All cells in column H





H:H

All cells in columns H through J




H:J

You can also use a reference style where both the rows and the columns on the worksheet are numbered. R1C1 style is useful for computing row and column positions in macros and can be useful for showing relative cell references. In R1C1 style, Microsoft Excel indicates the location of a cell with an "R" followed by a row number and a "C" followed by a column number.

Depending on the task you want to perform in Microsoft Excel, you can use either relative cell references, which are references to cells relative to the position of the formula, or absolute references, which are cell references that always refer to cells in a specific location. 

The difference between relative and absolute references

When you create a formula, references to cells or ranges are usually based upon their position relative to the cell that contains the formula. In the following example, cell B6 contains the formula =A5; Microsoft Excel finds the value one cell above and one cell to the left of B6. This is known as a relative referencing.

When you copy a formula that uses relative references, the references in the pasted formula update and refer to different cells relative to the position of the formula. In the following example, the formula in cell B6 has been copied to cell B7. The formula in cell B7 has changed to =A6, which refers to the cell that is one cell above and to the left of cell B7.

If you don't want references to change when you copy a formula to a different cell, use an absolute reference. For example, if your formula multiples cell A5 with cell C1 (=A5*C1) and you copy the formula to another cell, both references will change. You can create an absolute reference to cell C1 by placing a dollar sign ($) before the parts of the reference that do not change. To create an absolute reference to cell C1, for example, add dollar signs to the formula as follows:   =A5*$C$1

About worksheet functions

Microsoft Excel contains many predefined, or built-in, formulas known as functions. Functions can be used to perform simple or complex calculations. The most common function in worksheets is the SUM function, which is used to add ranges of cells. Although you can create a formula to calculate the total value of a few cells that contain values, the SUM worksheet function calculates several ranges of cells. 

Using functions to calculate values

Functions are predefined formulas that perform calculations by using specific values, called arguments, in a particular order, called the syntax. For example, the SUM function adds values or ranges of cells. Arguments can be numbers, text, logical values such as TRUE or FALSE, arrays, error values such as #N/A, or cell references. The argument you designate must produce a valid value for that argument. Arguments can also be constants, formulas, or other functions.

 The syntax of a function begins with the function name, followed by an opening parenthesis, the arguments for the function separated by commas, and a closing parenthesis. If the function starts a formula, type an equal sign (=) before the function name. As you create a formula that contains a function, the Formula Palette will assist you .

Using the Formula Palette

When you create a formula that contains a function, the Formula Palette helps you enter worksheet functions. As you enter a function into the formula, the Formula Palette displays the name of the function, each of its arguments, a description of the function and each argument, the current result of the function, and the current result of the entire formula. To display the Formula Palette, click Edit Formula    in the formula bar.

You can use the Formula Palette to edit functions in formulas. Select a cell that contains a formula, and then click Edit Formula    to display the Formula Palette. The first function in the formula and each of its arguments are displayed in the palette. You can edit the first function or edit another function in the same formula by clicking in the formula bar anywhere within the function.

To enter a formula that contains a function

1
Click the cell in which you want to enter the formula.

2
To start the formula with the function, click Edit Formula    in the formula bar.

3
Click the down arrow next to the Functions box  .

4
Click the function you want to add to the formula. If the function does not appear in the list, click More Functions for a list of additional functions.

5
Enter the arguments.

6
When you complete the formula, press ENTER.

Working with Charts

Create a chart

You can display Microsoft Excel data graphically in a chart. Charts are linked to the worksheet data they are created from and are updated when you change the worksheet data.  You can create charts from cells or ranges.

To create either an embedded chart or a chart sheet.

1
Select the cells that contain the data that you want to appear in the chart. 

2
If you want the column and row labels to appear in the chart, include the cells that contain them in the selection.

3
Click Chart Wizard & follow the instructions in the Chart Wizard.

Tip   If your worksheet has multiple levels of row and column labels, your chart can also display those levels. When you create the chart, include the row and column labels for each level in your selection. To preserve the hierarchy when you add data to the chart, change the cell range used to create the chart. For more information about changing the cell range, click  .

To Create a default chart in one step

The default chart type for Microsoft Excel is a column chart, unless you have changed it

1
To create a chart sheet that uses the default chart type, select the data you want to plot, and then press F11.

2
To create an embedded chart that uses the default chart type, select the data you want to plot, and then click Default Chart  .  If the Default Chart button is not available, add it to a toolbar.

Change values in a chart

The values in a chart are linked to the worksheet from which the chart is created. The chart is updated when you change the data on the worksheet.

1
Open the worksheet that contains the data plotted in the chart.

2
In the cell that contains the value you want to change, type a new value.

3
Press ENTER.

Edit chart and axis titles

1
Click the title you want to change.

2
Type the new text you want.

3
Press ENTER.

To Add data labels to a chart

The chart type associated with the selected data series or data point determines the type of label you can add.
To add data labels to a data series, click the data series.

To add a data label to a single data point, click the data series that contains the data marker you want to label, and then click the data marker for the data point you want to label.

1
On the Format menu, click Data Series or Data Point.

2
On the Data Labels tab, select the options you want.

To Add or change a title in a chart and axis

1
Click the chart to which you want to add a title.

2
On the Chart menu, click Chart Options, and then click the Titles tab.

3
To add a chart title, click in the Chart title box, and then type the text you want.

To add one or more axis titles, click in the appropriate box for each title, and then type the text you want.

Tip   To insert a line break in a chart title or axis title, click the text on the chart, click where you want to insert the line break, and then press ENTER.

To Add a legend to a chart

1
Click the chart to which you want to add a legend.

2
On the Chart menu, click Chart Options, and then click the Legend tab.

3
Select the Show legend check box.

4
Under Placement, click the option you want.

Note   When you click one of the Placement options, the legend moves, and the plot area automatically adjusts to accommodate it. If you move and size the legend by using the mouse, the plot area does not automatically adjust. When you use the Placement options, the legend loses any custom sizing you may have already applied by using the mouse.

To Display or hide gridlines in a chart

(Pie and doughnut charts do not have gridlines.)
1
Click the chart to which you want to add gridlines.

2
On the Chart menu, click Chart Options, and then click the Gridlines tab.

3
Select the check boxes for the gridlines you want to display.

4
Clear the check boxes for the gridlines you want to hide.

Note   To attach the data table to the category axis in a 3-D chart, click 3-D View on the Chart menu, and then select the Right angle axis check box.

Size and set up a chart for printing

If the chart is embedded on a worksheet, you can adjust where it will print on the page by sizing and moving the chart with the mouse in page break view.To do this, click the worksheet outside of the chart area, and then click Page Break Preview on the View menu.

If you're working with a chart sheet, you can size and scale the chart area, specify how it should be placed on the printed page, and then view it in the preview window. To set printing options for a chart sheet, click the tab for the chart sheet, click Page Setup on the File menu, and then select the options you want on the Chart tab.

To move and size the chart area of a chart sheet by using the mouse, you must click Custom on the Chart tab and then click OK to return to the chart sheet.

Note   To print an embedded chart without its associated worksheet data, click the embedded chart to select it, and then follow the preceding instructions for chart sheets. 

Zoom or size the display of a chart sheet

1
Click the tab for the chart sheet.

2
To zoom in or out of a chart sheet, click Zoom on the View menu, and then click the option you want.

3
To size the chart sheet so that it fills the entire workbook window, click Sized with Window on the View menu. When a chart sheet is sized with the window, you cannot zoom in or out of it.

Changing the type of a Chart

For most 2-D charts, you can change the chart type of either a data series or the entire chart. For bubble charts, you can change only the type of the entire chart. For most 3-D charts, changing the chart type affects the entire chart. For 3-D bar and column charts, you can change a data series to the cone, cylinder, or pyramid chart type.

1
Click the chart you want to change.

2
To change the chart type of a data series, click the data series.

To change the chart type of the entire chart, don't click anything on the chart.

3
On the Chart menu, click Chart Type.

4
On the Standard Types or Custom Types tab, click the chart type you want.

Ways to select chart items

To select a chart item by using the mouse, do one of two things:

1
Click the chart item you want. Data series, data labels, and the legend have individual elements that can be selected after you select the group. For example, to select a single data marker in a data series, click the data series, and then click the data marker. Microsoft Excel displays the name of a chart item in a tip when you rest the pointer over the item if you have the Show names check box selected (Tools menu, Options command, Chart tab).

2
Click the chart, click the arrow next to the Chart Objects box    on the Chart toolbar, and then click the item you want.

3
To select a chart item by using the keyboard, use the arrow keys.

4
To cancel a selection, press ESC.

Change colors, patterns, lines, fills, and borders in charts

Use this procedure to change colors, apply a texture or pattern, or change the line width or border style for data markers, the chart area, the plot area, gridlines, axes, and tick marks in 2-D and 3-D charts, trendlines and error bars in 2-D charts, and the walls and floor in 3-D charts.

1
Double-click the chart item you want to change.

2
If necessary, click the Patterns tab, and then select the options you want.

To specify a fill effect, click Fill Effects, and then select the options you want on the Gradient, Texture, and Pattern tabs. 

Note   Formatting applied to an axis is also applied to the tick marks on that axis. Gridlines are formatted independently of axes.

To Align text in chart titles and text boxes

1
Click the title or the border of the text box you want to align.

2
If you clicked an axis title, click Axis Title on the Format menu.

3
If you clicked a chart title, click Chart Title on the Format menu.

4
If you clicked a text box, click Text Box on the Format menu.

5
Click the Alignment tab.

6
If you don't see the Alignment tab, click Cancel, click outside of the text you want to format, and then repeat steps 1-3.

4
Select the options you want.

Rotate text in a chart title or along an axis

You can rotate, or "angle," text in a chart title or along an axis. You cannot rotate legend text.

1
Click the axis or the title you want to format.

2
If you clicked an axis, click Axis on the Format menu.

If you clicked an axis title, click Axis Title on the Format menu.

3
Click the Alignment tab.

If you don't see the Alignment tab, click Cancel, click outside of the text you want to format, and then repeat steps 1-3.

4
To rotate text, under Orientation, click a degree point, or drag the indicator to the position you want.

Tip   To quickly rotate selected text 45 degrees up or down, click Angle Text Upward    or Angle Text Downward    on the Chart toolbar.

Change number formats in charts

If you change the number formatting in a chart, the number formatting is no longer linked to the worksheet cells.

1
To format labels along an axis, double-click the appropriate axis.

2
To format data labels or a trendline label, double-click the item.

3
On the Number tab, select the options you want.

Managing Lists

Using a list as a database

In Microsoft Excel, you can easily use a list as a database. When you perform database tasks, such as finding, sorting, or subtotaling data, Microsoft Excel automatically recognizes the list as a database and uses the following list elements to organize the data.

·
The columns in the list are the fields in the database.

·
The column labels in the list are the field names in the database.

·
Each row in the list is a record in the database.

Guidelines for creating a list on a worksheet

Microsoft Excel has a number of features that make it easy to manage and analyze data in a list. To take advantage of these features, enter data in a list according to the following guidelines.

List size and location

·
Avoid having more than one list on a worksheet. Some list management features, such as filtering, can be used on only one list at a time.

·
Leave at least one blank column and one blank row between the list and other data on the worksheet. Microsoft Excel can then more easily detect and select the list when you sort, filters, or insert automatic subtotals.

·
Avoid putting blank rows and columns in the list so that Microsoft Excel can more easily detect and select the list.

·
Avoid placing critical data to the left or right of the list; the data might be hidden when you filter the list.

Column labels

·
Create column labels in the first row of the list. Microsoft Excel uses the labels to create reports and to find and organize data.

·
Use a font, alignment, format, pattern, border, or capitalization style for column labels that is different from the format you assign to the data in the list.

·
When you want to separate labels from data, use cell borders ¾ not blank rows or dashed lines  to insert lines below the labels.

Row and Column Contents

·
Design the list so that all rows have similar items in the same column.

·
Don't insert extra spaces at the beginning of a cell; extra spaces affect sorting and searching.

·
Don't use a blank row to separate column labels from the first row of data.

Sort a list

You can rearrange the rows or columns of a list based on the values in the list by sorting. When you sort, Microsoft Excel rearranges rows, columns, or individual cells by using the sort order that you specify. You can sort lists in ascending (1 to 9, A to Z) or descending (9 to 1, Z to A) order, and sort based on the contents of one or more columns.

Microsoft Excel sorts lists alphabetically by default. If you need to sort months and weekdays according to their calendar order instead of their alphabetic order, use a custom sort order. You can also rearrange lists in a specific order by creating custom sort orders. For example, if you have a list that contains the entry "Low," "Medium," or "High" in a column, you can create a sort order that arranges rows that contain "Low" first, rows that contain "Medium" next, and rows with "High" last.

Default sort orders

Microsoft Excel uses specific sort orders to arrange data according to the value, not the format, of the data.

When you sort text, Microsoft Excel sorts left to right, character by character. For example, if a cell contains the text "A100," the cell will sort after a cell that contains the entry "A1" and before a cell that contains the entry "A11."

In an ascending sort, Microsoft Excel uses the following order. (In a descending sort, this sort order is reversed except for blank cells, which are always sorted last.)

·
Numbers are sorted from the smallest negative number to the largest positive number.

Sort rows in ascending /descending order based on the contents of one column

If you previously sorted a list on the same worksheet, Microsoft Excel uses the same sorting options unless you change them.

1
Click a cell in the column you would like to sort by.

Click Sort Ascending (A-Z)/ descending  (Z-A).

Sort rows based on the contents of two or more columns

For best results, the list you sort should have column labels.

1
Click a cell in the list you want to sort.

2
On the Data menu, click Sort.

3
In the Sort by and Then by boxes, click the columns you want to sort. 

If you need to sort by more than three columns, sort by the least important columns first. For example, if your list contains employee information and you need to organize it by Department, Title, Last Name, and First Name, sort the list twice. First, click First Name in the Sort by box and sort the list. Second, click Department in the Sort by box, click Title in the first Then by box, and click Last Name in the second Then by box, and sort the list.

4
Select any other sort options you want, and then click OK.

Repeat steps 2 through 4 if needed, using the next most important columns.

Display a subset of rows in a list by using filters

You can apply filters to only one list on a worksheet at a time.

1
Click a cell in the list you want to filter.

2
On the Data menu, point to Filter, and then click AutoFilter.

3
To display only the rows that contain a specific value, click the arrow in the column that contains the data you want to display.

4
Click the value.

5
To apply an additional condition based on a value in another column, repeat steps 3 and 4 in the other column.

To filter the list by two values in the same column, or to apply comparison operators other than Equals, click the arrow in the column, and then click Custom. For information about displaying rows by comparing values, click.

Display a subset of rows by comparing values

To find specific values in rows in a list by using one or two comparison criteria for the same column, click the arrow in the column that contains the data you want to compare, and then click Custom.

·
To match one criterion, click the comparison operator you want to use in the first box under Show rows where, and then enter the value you want to match in the box immediately to the right of the comparison operator.

·
To display rows that meet two conditions, enter the comparison operator and value you want, and then click the And button. In the second comparison operator and value boxes, enter the operator and value you want.

·
To display rows that meet either one condition or another condition, enter the comparison operator and value you want, and then click the Or button. In the second comparison operator and value boxes, enter the operator and value you want.

Remove filters from a list

·
To remove a filter from one column in a list, click the arrow next to the column, and then click All.

·
To remove filters applied to all columns in the list, on the Data menu point to Filter, and then click Show All.

·
To remove the filter arrows from a list, on the Data menu point to Filter, and then click AutoFilter.

Types of comparison criteria

You can use the following types of comparison criteria in a criteria range, with either an advanced filter or a custom filter.

A series of characters

To find rows in a list that contain an exact value, type the text, number, date, or logical value in the cell below the criteria label. For example, if you type 98133 below a Postal Code label in the criteria range, Microsoft Excel displays only rows that contain the postal code value "98133."

When you use text as criteria with an advanced filter, Microsoft Excel finds all items that begin with that text. For example, if you type the text Mas as a criterion, Microsoft Excel finds "Master," "Mason" and "Masa." To match only the specified text, type the following formula, where text is the text you want to find.

=''=text''

Wildcard characters

To find text values that share some characters but not others, use a wildcard character. A wildcard character represents one or more unspecified characters.

Insert subtotal values into a list

In a long list of data, you can use subtotals to automatically outline the information on a worksheet. You can "nest," or insert, subtotals for smaller groups within subtotal groups, which is useful when you need to calculate subtotals within groups of values. You can remove subtotals from a list without affecting your original data.

To Insert subtotals into a list

1
Sort the list by the column for which you wants to calculate subtotals. For example, to summarize the units sold by each salesperson in a list of salespeople, sales amounts, and the number of units sold, sort the list by the salesperson column.

2
Click a cell in the list.

On the Data menu, click Subtotals.

In the At each change in box, click the column that contains the groups for which you want subtotals. This should be the same column by which you sorted your list in step 

3
In the Use function box, click the function you want to use to calculate the subtotals. For information about the summary functions, click  .

In the Add subtotal to box, select the check boxes for the columns that contain the values for which you want subtotals.

Remove subtotals from a list

When you remove subtotals from a list, Microsoft Excel also removes the outline and all page breaks that were inserted into the list when you inserted the subtotals.

1
Click a cell in the list that contains subtotals.

2
On the Data menu, click Subtotals.

3
Click Remove All.

Using functions to calculate values.

Functions are predefined formulas that perform calculations by using specific values, called arguments, in a particular order, called the syntax. For example, the SUM function adds values or ranges of cells.

Arguments can be constants, formulas, or other functions.

 The syntax of a function begins with the function name, followed by an opening parenthesis, the arguments for the function separated by commas, and a closing parenthesis. If the function starts a formula, type an equal sign (=) before the function name. As you create a formula that contains a function, the Formula Palette will assist you .

DATEVALUE

Returns the serial number of the date represented by date_text. Use DATEVALUE to convert a date represented by text to a serial number.

Syntax    DATEVALUE(date_text)

Date_text   is text that returns a date in a Microsoft Excel date format. Using the default date system in Microsoft Excel for Windows, date_text must represent a date from January 1, 1900, to December 31, 9999. Using the default date system in Microsoft Excel for the Macintosh, date_text must represent a date from January 1, 1904, to December 31, 9999. DATEVALUE returns the #VALUE! error value if date_text is out of this range.

TODAY

Returns the serial number of the current date. The serial number is the date-time code used by Microsoft Excel for date and time calculations. For more information about serial numbers, see NOW.
Syntax  TODAY( )

NOW

Returns the serial number of the current date and time.

Syntax  NOW( )

About logical functions

You can use the logical functions either to see whether a condition is true or false or to check for multiple conditions. For example, you can use the IF function to determine whether a condition is true or false: One value is returned if the condition is true, and a different value is returned if the condition is false.

IF function

Returns one value if a condition you specify evaluates to TRUE and another value if it evaluates to FALSE. Use IF to conduct conditional tests on values and formulas.

Syntax  IF(logical_test,value_if_true,value_if_false)

Logical_test   is any value or expression that can be evaluated to TRUE or FALSE.

Value_if_true   is the value that is returned if logical_test is TRUE. If logical_test is TRUE and value_if_true is omitted, TRUE is returned. Value_if_true can be another formula.

Value_if_false   is the value that is returned if logical_test is FALSE. If logical_test is FALSE and value_if_false is omitted, FALSE is returned. Value_if_false can be another formula.

AND

Returns TRUE if all its arguments are TRUE; returns FALSE if one or more arguments is FALSE.

Syntax  AND(logical1,logical2, ...)

OR

Returns TRUE if any argument is TRUE; returns FALSE if all arguments are FALSE.

Syntax   OR(logical1,logical2,...)

Logical1,logical2,...   are 1 to 30 conditions you want to test that can be either TRUE or FALSE.

About math functions

With math and trigonometry functions, you can perform simple and complex mathematical calculations, such as calculating the total value for a range of cells or the total value for a range of cells that meet a condition in another range of cells, or round numbers.

INT

Rounds a number down to the nearest integer.

Syntax   INT(number)

Number   is the real number you want to round down to an integer.

Example   INT(8.9) equals 8

SUM

Adds all the numbers in a range of cells.

Syntax   SUM(number1,number2, ...)

Number1, number2, ...   are 1 to 30 arguments for which you want the total value or sum.

About statistical functions

Statistical worksheet functions perform statistical analysis on ranges of data. For example, a statistical worksheet function can provide statistical information about a straight line plotted through a group of values, such as the slope of the line and the y-intercept, or about the actual points that make up the straight line.

AVERAGE

Returns the average (arithmetic mean) of the arguments.

Syntax  AVERAGE(number1,number2, ...)

Number1, number2, ...   are 1 to 30 numeric arguments for which you want the average.

MAX

Returns the largest value in a set of values.

Syntax   MAX(number1,number2,...)

MIN

Returns the smallest number in a set of values.

Syntax   MIN(number1,number2, ...)

Number1, number2,...   are 1 to 30 numbers for which you want to find the minimum value.
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